Login to start a new topic

Switching to Fiddler Everywhere 1.0 broke my internet

On Mac OS Mojave.


Here is what I think happened:

  1. I started an older version of Fiddler Everywhere (probably 0.5, but I'm not sure)
  2. It asked for my system password to configure proxy settings
  3. I got a download prompt about a new version
  4. I Cmd+Q in Fiddler Everywhere (This typically would break internet.  You have to properly exit in order to properly tear down the proxy settings.)
  5. When I launched Fiddler again, it was the 1.0 version

All web applications (ie. Chrome/Safari) report "No Internet Connection" unless Fiddler is running.

I tried the following:
  • Rebooting does not fix this. 
  •  When I exit Fiddler 1.0, there are no obvious or visible proxy changes in Settings > Network > Advanced > Proxies
  • I tried to find a download link for v0.5.0, so I could reinstall that, start it and exit it properly.  However, the download link for previous versions is not available.

Please help... I'm stuck. 


Hello Greg,


I am sorry to hear that the issue persists. 


We are aware of the known issue that you linked, we are just not certain if installing an older version of the client will resolved the current problem. We are continuing to look for a resolution that does not involve installing an old version of the client. Nevertheless, I will still ask my colleagues if they can provide an older version of the client (v0.5.0) and if they do, I'll share it in my next reply.


Regarding your message not making it through, it did, but we are moderating posts that contain links, and that caused some delay.


Regards,

Garo Garabedian


1 person likes this

Hello Greg,


I am sorry to hear that you are having issues with the new version of Fiddler Everywhere.


I noticed that you have already examined the Proxies settings and everything there appears to be in order. Nevertheless, since this is the most common cause for such behavior, I would ask you to try the steps outlined below before we look for other possibilities.

  1. Make sure that Fiddler Everywhere is not running.
  2. Open System Preferences -> Network.
  3. In the Network dialog, select the active adapter (for example, Wi-Fi) and click Advanced.
  4. In the new dialog (the settings of the selected active adapter), select Proxies and disable Web Proxy (HTTP) and Secure Web Proxy (HTTPS). Click OK to close the dialog and then Apply to save the changes.


Let me know if this helps.


Regards,

Garo Garabedian

Following those steps, I can confirm that there are no checked boxes in the settings (see screenshot).


When I exit Fiddler, the proxy settings are still stored here:

~$ scutil --proxy

<dictionary> {

 FTPEnable : 0

 HTTPEnable : 1

 HTTPPort : 8866

 HTTPProxy : 127.0.0.1

 HTTPSEnable : 1

 HTTPSPort : 8866

 HTTPSProxy : 127.0.0.1

 ProxyAutoConfigEnable : 0

 ProxyAutoDiscoveryEnable : 0

 SOCKSEnable : 0

}

But not here:

~$ networksetup -getwebproxy Wi-Fi

Enabled: No

Server: 

Port: 0

Authenticated Proxy Enabled: 0

~$ networksetup -getsecurewebproxy Wi-Fi

Enabled: No

Server: 

Port: 0

Authenticated Proxy Enabled: 0


How do I clear out the system wide proxy?

Greg,


This is strange, I haven't seen such behavior so far and I cannot reproduce the issue.


The commands that you are looking for should be:
 

networksetup -setwebproxystate "Wi-Fi" off
networksetup -setsecurewebproxystate "Wi-Fi" off


However, the steps provided in the previous response should do the same. Can you confirm that you are doing this for the active adapter? Also, can you share an image of the Network dialog?


Regards,

Garo Garabedian

I'm not sure if my previous reply made it through...

Those networksetup commands don't improve my situation.  I have attached a screenshot of the network settings dialog -- however, it's pretty standard.


Did you see my comment above about hard-exiting the previous version of Fiddler Everywhere?  There was a known issue with that version which would leave your network settings in an inconsistent state.


The fix was to simply restart Fiddler and properly exit.  On both start/stop it would request your password.


I believe that's what happened here.   Can you give me a link to a previous version of Fiddler Everwhere for Mac?  

Greg,


You can use the following link to download version 0.5.0 of the Fiddler Everywhere client.


We identified some key changes between the two versions that would explain this behavior but we haven't made progress on finding an alternative resolution to this issue. Please, let me know if you were able to resolve the issue with the help of the older version.


Regards,

Garo Garabedian



0.5.0 didn't seem to help.  I got the password prompt on startup & exit, but afterwards was still unable to access webpages.


However, I plugged an ethernet adapter into this Macbook Pro.  That changed the output of:

~$ scutil --proxy
<dictionary> {
  ExceptionsList : <array> {
    0 : *.local
    1 : 169.254/16
  }
  FTPPassive : 1
}

 and I was able to access webpages without Fiddler running.


Switching back to Wi-Fi:

~$ scutil --proxy
<dictionary> {
  FTPEnable : 0
  HTTPEnable : 0
  HTTPSEnable : 0
  ProxyAutoConfigEnable : 0
  ProxyAutoDiscoveryEnable : 0
  SOCKSEnable : 0
}

 

I am cautiously optimistic that my machine is working again. 

Login to start a new topic