Fiddler Anywhere 1.0.1 got stuck on launch

Hello,

Could you please help to start Fiddler on my mac?

I installed Fillder Everywhere v.1.0.1. on my Mac OS Catalina system and launch it, but it stuck with endless 'Please Wait' splash screen. In parallel it configured my network (both HTTP & HTTPS ) to run via proxy 172.0.0.1:8866, but the proxy didn't start  (it stuck with splash screen) and thus no i-net connection available. 


While fiddler was in this endless launching state i opened system.log and noticed following:

...

Aug 13 10:22:37 macbookZZZ com.apple.xpc.launchd[1] (com.apple.locate[75065]): Service exited with abnormal code: 1

Aug 13 10:22:37 macbookZZZ com.apple.xpc.launchd[1] (com.apple.locate): Service only ran for 0 seconds. Pushing respawn out by 10 seconds.

Aug 13 10:22:40 macbookZZZ com.apple.xpc.launchd[1] (com.apple.mdworker.shared.0B000000-0400-0000-0000-000000000000[75019]): Service exited due to SIGKILL | sent by mds[183]

...
Could you please advise if these logs are related to the fiddler? If yes, why the service was killed?


Thanks in advance!


Hey  Richard.carver,


Your issue is most likely caused by a different cause as you are using Windows and the above thread is discussing a macOS specific issue. Btw were you able to reproduce the problem  after have recovered for the issue with manually resetting the OS proxy settings)? If so, you could send us additional information about your default network configuration and the Fiddler log files.

I have the same symptom, but different cause I think. On Windows 10 my Fiddler Everywhere was stuck after the login page. It turned out it had previously set my internet proxy to a port on localhost so neither Fiddler Everywhere or any other browser on the computer could reach the internet. I disabled the proxy in Windows settings and it started working.
It seems like an omission in the software not to auto-recover from this.

Hey everyone,


The team recently introduced version 1.1.0, which comes with fixes from some previously unsupported network scenarios. For example, with the new release, Fiddler Everywhere will now work in cases where there is a pre-set proxy configuration. It will support multiple active network adapters and support the VPN setup (see this KB article). 


However, an active internet connection is still required (due to the login endpoints), and also some scenarios where the internet access on Mac depends on PAC might not work correctly. Let us know if you are experiencing an issue with the latest 1.1.0 version (and in such cases, please provide details on your network configuration - proxy settings, used VPN & security tools, etc.,)

Yes Deanna, same for me on the URLs. While it was mentioned to whitelist some endpoints, getting a large corporation to do this will not likely happen, I would think the option of having an option to disable the login would easily correct the issue.

The three getfiddler URLs that Garo mentioned look the same in my browser whether or not I have the VPN running, but Fiddler only starts with the VPN off.

Would it be possible for Fiddler to time out and fall back to Free tier mode when this problem happens?

The VPN requirement is a significant inconvenience for my team as well. I get the same response to loading the 3 mentioned sites in my browser whether or not I have the VPN running:

https://login.getfiddler.com/ => "Cannot GET /" message
https://api.getfiddler.com => Login dialog appears 
https://auth.getfiddler.com/ => Page is blank. Browser tab shows the page title is Signin 

Well, I didn't realize there is a timeout. Seems my session timed out later in the day. I once again had to disconnect from my corp VPN to get Fiddler Everywhere to work. Of course this interrupts my VoIP and corp chat, among other internal corp sites. Could someone explain why we need to log in to your site to use Fiddler Everywhere? Thanks...

I had the same problem. Uninstalling, clearing folders and re-installing did not help. Mmarkust's solution to start VPN after Fiddler Everywhere worked for me.  I am using Pritunl VPN and Carbon Black.

ok, the only thing good is that issue is reproducible not only on my Mac.


Thanks, Mmarkust. I turned off VPN, cleared folders (~/.fiddler/ and ~/Library/Application Support/Fiddler Everywhere/) and tried again, but still no luck. 



I've run into this issue as well. However, I've confirmed the issue is when trying to start Fiddler Everywhere v1.0.1 after connecting to my corporate VPN. If I disconnect from VPN, Fiddler starts within seconds. Since I mainly just need Fiddler to review customer trace files, I can workaround this by starting my VPN after starting Fiddler Everywhere. 


I'm using macOS Catalina 10.15.6.

 

[2020-08-23 13:12:09:352] [info] [Product information] Fiddler Everywhere 1.0.1
[2020-08-23 13:12:09:362] [info] [System information] Darwin MacBook-Pro 19.6.0 Darwin Kernel Version 19.6.0: Thu Jun 18 20:49:00 PDT 2020; root:xnu-6153.141.1~1/RELEASE_X86_64 x86_64
[2020-08-23 13:12:09:416] [info] Initializing splash screen.
[2020-08-23 13:12:09:495] [info] Attempting to run server - 5 attempts left.
[2020-08-23 13:12:09:496] [info] Calculating the URL of ASP.NET Server application.
[2020-08-23 13:12:09:496] [info] Generating random port.
[2020-08-23 13:12:09:496] [info] Trying to start server at port [12383].
[2020-08-23 13:12:10:273] [info] Fetching .NET Core server status.
[2020-08-23 13:12:10:359] [info] Application successfully connected to .NET Core server [12383].
[2020-08-23 13:12:10:360] [info] Loading application in window.
[2020-08-23 13:12:10:388] [info] Getting the URL of Angular application.
[2020-08-23 13:12:10:410] [info] Starting the app without a deep link.
[2020-08-23 13:12:10:410] [info] Maximizing application window.
[2020-08-23 13:12:12:192] [info] Destroying splash screen.
[2020-08-23 13:12:12:235] [info] Checking for update
[2020-08-23 13:12:12:334] [info] Generated new staging user ID: 75dddabc-2422-5505-a56e-XXXXXXXXXXXX
[2020-08-23 13:12:12:757] [info] Update for version 1.0.1 is not available (latest version: 1.0.1, downgrade is disallowed).


[2020-08-23 13:12:12:322] [Information] [Angular] Requesting shared item ID.
[2020-08-23 13:12:12:350] [Information] [Angular] CleverTap analytics successfully initialized.
[2020-08-23 13:12:12:350] [Information] [Angular] Successfully set anonymous user information in CleverTap.
[2020-08-23 13:12:12:351] [Information] [Angular] The app will be loaded without navigating to a shared item.
[2020-08-23 13:12:12:367] [Information] [Angular] SignalR HubConnection connected successfully.
[2020-08-23 13:12:12:419] [Information] [Angular] WebSocket opened ws://localhost:12383/ws/sessionListData
[2020-08-23 13:12:12:422] [Information] [Angular] Has Internet Access during the user service creation: true.
[2020-08-23 13:12:45:664] [Information] [Angular] Logged in from the amplify SDK.
[2020-08-23 13:12:45:665] [Information] [Angular] Token assumed as outdated or risky.
[2020-08-23 13:12:45:665] [Information] [Angular] Received id Token. Had existing tokens: 'false'. Is new token: 'true'. Index in history: '0'. Total tokens in history: '1'.
[2020-08-23 13:12:45:665] [Information] [Angular] Will try to refresh user's token
[2020-08-23 13:12:45:820] [Information] [Angular] Starting a new backend login.
[2020-08-23 13:12:45:820] [Information] [Angular] New idToken successfully taken.
[2020-08-23 13:12:45:820] [Information] [Angular] Received id Token. Had existing tokens: 'true'. Is new token: 'false'. Index in history: '0'. Total tokens in history: '1'.
[2020-08-23 13:12:46:287] [Information] [Fiddler] When connecting, upstream proxy settings were already pointed at Fiddler. Clearing upstream proxy.

 

 

@MacBook-Pro Logs % wget https://login.getfiddler.com/
--2020-08-23 13:23:26--  https://login.getfiddler.com/
Resolving login.getfiddler.com (login.getfiddler.com)... 34.231.200.49, 52.72.68.125
Connecting to login.getfiddler.com (login.getfiddler.com)|34.231.200.49|:443... connected.
HTTP request sent, awaiting response... 404 Not Found
2020-08-23 13:23:27 ERROR 404: Not Found.

@MacBook-Pro Logs % wget https://api.getfiddler.com/
--2020-08-23 13:23:32--  https://api.getfiddler.com/
Resolving api.getfiddler.com (api.getfiddler.com)... 52.72.68.125, 34.231.200.49
Connecting to api.getfiddler.com (api.getfiddler.com)|52.72.68.125|:443... connected.
HTTP request sent, awaiting response... 301 Moved Permanently
Location: index.html [following]
--2020-08-23 13:23:33--  https://api.getfiddler.com/index.html
Reusing existing connection to api.getfiddler.com:443.
HTTP request sent, awaiting response... 200 OK
Length: unspecified [text/html]
Saving to: ‘index.html’

@MacBook-Pro Logs % wget https://auth.getfiddler.com/
--2020-08-23 13:23:38--  https://auth.getfiddler.com/
Resolving auth.getfiddler.com (auth.getfiddler.com)... 13.226.217.113, 13.226.217.11, 13.226.217.56, ...
Connecting to auth.getfiddler.com (auth.getfiddler.com)|13.226.217.113|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: unspecified [text/html]
Saving to: ‘index.html.1’

 

It looks like I am having the same issue. I am not running 3rd party AV or Firewalls

Hello,


Thank you for narrowing down what is causing the issue and specifying that the problem is related to the Mac and not to the account. 


The current Fiddler Everywhere system requirements are noted in our documentation. The only firewall related requirement is to have access to the following three URLs:

  • https://login.getfiddler.com/
  • https://api.getfiddler.com/
  • https://auth.getfiddler.com/


You already confirmed that you have access to the second one (API), where you are seeing the correct behavior - you are asked for a login


We have logged an internal item to investigate how we can improve the client to detect antivirus or firewall issues. At the moment, the only way would be for you to share details about your firewall and antivirus software, so we attempt to reproduce the issue on our end. Can you tell us something more about those? Since the information might be sensitive and you wouldn't want to share it in a public forum, please send any details you can share to support@getfiddler.com.

btw, I successfully signed in with the new account on the second mac. So, I believe on my main mac this  process is blocked by antivirus, firewall or some other stuff.. 


Could you please give any ideas or recommendations where I can look into or check ?