Proxy only gets automatically setup for Wi-Fi.

So, does anyone use Fiddler Everywhere with Ethernet? I certainly do, and to do it is a such a hassle. I literally have to go to the Network Panel in System Preferences and manually change the web proxy and secure web proxy settings to direct traffic through Fiddler.

When I close Fiddler, I have to remember to remove the proxy. It's a pain.

This is an issue on every Mac I've tested on; it's a pretty glaring issue in my opinion; I don't know who decided that this software was ready to move out of beta when something as basic as this hasn't even been addressed.

My expectation, is that like Fiddler 4 on Windows, is that the darn thing should just work. Period.

Hello Tylerabahr,

Thank you for your interest in Fiddler Everywhere and the feedback!

I've tested the described scenario on my MacBook (macOS Mojave 10.14.6), and I was able to use Fiddler Everywhere client alongside Ethernet connection, WiFi connection, and both connections turned on. I've also started and stopped the Fiddler Everywhere client multiple times, and the proxy was successfully changed without losing internet connectivity. Please provide more details on the macOS version and any details about your environment and setup related to network connectivity (e.g., let us know if you are using specific network/antivirus tools or VPN software).

Tylerabahr thank you once again for your valued feedback and observations!

We've identified specific cases where resetting the proxy settings is not working as expected. The team is working on a fix that will set/remove the proxy from all active adapters on macOS.

Hello Everyone,

The team just released the new version 1.1.0 of Fiddler Everywhere client. The release contains a fix for the described scenario above and should now seamlessly work with multiple active network adapters and with pre-set proxy settings.

Tylerabahr, we will appreciate if you have the time to download and install the latest version and test it against your environment.

I'm out of town at the moment, so I haven't had the chance yet to test if multiple network adapters work, but I can already tell using wi-fi, that this something is not right. It no longer even sets up the proxy for that.

Hey @Tylerabahr,

That is definitely not expected. Can you please provide us the logs located at ~/Library/Application Support/Fiddler Everywhere/Logs for investigation. Also, it will be a great help if you can provide information for your setup:
1. Do you have a proxy set prior starting Fiddler Everywhere?
2. Is you Wi-fi adapter named Wi-Fi?

3. Are you admin of your machine, i.e. when you use the command `groups` in your terminal, does the output contain `admin`?

4. Once Fiddler Everywhere starts, can you navigate to Settings -> Gateway and ensure Use system proxy is set.

5. When Fiddler Everywhere starts and capturing is started, can you check all of your network's interfaces and see if proxy is set on any of them?

Thanks in advance for your help on this case!