Login to start a new topic

Decrypt HTTPS Traffic

I'm not able to view web pages even though I'm capturing HTTPS traffic.  It's showing me clearly encrypted data in the Web tab like this.

image



I looked at this doc but it seems to be for a previous version of the product and I looked at this page which at least seems to be the same UI style as the product I downloaded, but I don't see this

image

I see this instead

image


What am I doing wrong?




Most of the responses are using additional compression or are encoded for the purpose of additional security. So to be able to read the content, you need to activate the Decode option from the Live Traffic toolbar menu (the second icon from the left). Refer to this documentation article for more details.


1 person likes this

Hi, I am having same issue with web browsers even with Decode turned on.

My Fiddler is setup properly to decrypt https traffic because when I point mobile device to it I can see https traffic decrypted.

image



But when I use web browser on mac the traffic is not decrypted.

image


Hey Loveleen.saini,


Thanks for sharing the screenshots. From them I could see that the Content-Encoding is BR (Brotli) which is currently not supported by Fiddler Everywhere. The issue is acknowledged by the team and there is a feature request logged here (which you could upvote).

Thanks for quick response. I have upvoted the feature request.

Hi Nick,


Is it Content-Encoding is gzip, is also not supported by Fiddler Everywhere to decode? Cos i get the similar weird characters from the raw response. I'm using Fiddler Everywhere on Linux.

if i removed gzip from the accept-encoding request, the raw response will be in readable html text.

Hey Koonmin25,


The GZIP decoding should work as expected. I've tested it on my side via


https://httpbin.org/gzip


And with Decode turned on the Raw inspector shows the following:


HTTP/1.1 200 OK
Date: Wed, 14 Oct 2020 10:25:07 GMT
Content-Type: application/json
Content-Length: 227
Connection: keep-alive
Server: gunicorn/19.9.0
Access-Control-Allow-Origin: *
Access-Control-Allow-Credentials: true

{
  "gzipped": true, 
  "headers": {
    "Host": "httpbin.org", 
    "User-Agent": "Fiddler Everywhere", 
    "X-Amzn-Trace-Id": "Root=1-5f86d203-6c49290c3136dbf619fbb4da"
  }, 
  "method": "GET", 
  "origin": "82.103.64.96"
}


Turning off the Decode option and replaying the request is immediately showing an encoded (GZIP-ed) content.


Login to start a new topic