Login to start a new topic
Implemented

Decode br encoding

The encoding br is not supported.


Desired behaviour:

Fiddler should decode response encoded with br (Brotli) so that I would be able to read them.


Actual behaviour:

Fiddler displays the raw encoded response which a human cannot read.


Workaround:

I can edit the request and remove 'br' from 'Accept-Encoding' header and send it again. Given it's possible to make the same request twice and the server handles other encodings, it may work.
It would be even better if I could automatically do that using a rule.

Update: The Brotli encoding is now fully supported in Fiddler Everywhere.

With the latest version (1.5.1) response body will be automatically decoded in all inspectors except for the Raw inspector, where we have a manual decode option (this provides an opportunity to see the original response vs. the decoded one)


1 person likes this

Great !

Login to start a new topic