Login to start a new topic

Fiddler Everywhere 1.1.0 wont authenticate

Whenever I open fiddler everywhere and try to log in via my email address and password, I get a network error (though my network works).  When I try to log in via google, it redirects to a webpage, authenticates successfully but throws an error when it returns to the app.  I tried uninstalling fully and reinstalling but it still happens.


When I look at the electron logs i see this:

 

[2020-09-24 09:38:49:807] [info] Closing server...
[2020-09-24 09:38:49:832] [info] Application exited with code 0.
[2020-09-24 09:38:55:825] [info] [Product information] Fiddler Everywhere 1.1.0
[2020-09-24 09:38:55:840] [info] [System information] Darwin gg-72GRJHD2-MBP 18.7.0 Darwin Kernel Version 18.7.0: Thu Jun 18 20:50:10 PDT 2020; root:xnu-4903.278.43~1/RELEASE_X86_64 x86_64
[2020-09-24 09:38:55:949] [info] Initializing splash screen.
[2020-09-24 09:38:55:951] [info] Attempting to run server - 5 attempts left.
[2020-09-24 09:38:55:952] [info] Calculating the URL of ASP.NET Server application.
[2020-09-24 09:38:55:952] [info] Generating random port.
[2020-09-24 09:38:55:953] [info] Trying to start server at port [13236].
[2020-09-24 09:38:57:268] [info] Fetching .NET Core server status.
[2020-09-24 09:38:57:384] [info] Application successfully connected to .NET Core server [13236].
[2020-09-24 09:38:57:537] [info] Setting the following proxy settings to the main window: {"pacScript":"http://corp-config.bamtechmedia.com/proxy.pac","proxyRules":null,"proxyBypassRules":"*.local,;169.254/16"}
[2020-09-24 09:38:57:559] [info] Loading application in window.
[2020-09-24 09:38:57:559] [info] Getting the URL of Angular application.
[2020-09-24 09:38:57:583] [info] Starting the app without a deep link.
[2020-09-24 09:38:57:583] [info] Maximizing application window.
[2020-09-24 09:38:58:437] [info] Destroying splash screen.
[2020-09-24 09:38:58:514] [info] Checking for update
[2020-09-24 09:38:58:633] [error] Error: Error: net::ERR_MANDATORY_PROXY_CONFIGURATION_FAILED
    at SimpleURLLoaderWrapper.<anonymous> (electron/js2c/browser_init.js:2519:21)
    at SimpleURLLoaderWrapper.emit (events.js:210:5)
From previous event:
    at GenericProvider.getLatestVersion (/Applications/Fiddler Everywhere.app/Contents/Resources/app/node_modules/electron-updater/src/providers/GenericProvider.ts:18:25)
    at /Applications/Fiddler Everywhere.app/Contents/Resources/app/node_modules/electron-updater/src/AppUpdater.ts:346:26
    at Generator.next (<anonymous>)
    at processImmediate (internal/timers.js:439:21)
From previous event:
    at MacUpdater.getUpdateInfoAndProvider (/Applications/Fiddler Everywhere.app/Contents/Resources/app/node_modules/electron-updater/src/AppUpdater.ts:335:43)
    at /Applications/Fiddler Everywhere.app/Contents/Resources/app/node_modules/electron-updater/src/AppUpdater.ts:362:31
    at Generator.next (<anonymous>)
From previous event:
    at MacUpdater.doCheckForUpdates (/Applications/Fiddler Everywhere.app/Contents/Resources/app/node_modules/electron-updater/src/AppUpdater.ts:359:34)
    at MacUpdater.checkForUpdates (/Applications/Fiddler Everywhere.app/Contents/Resources/app/node_modules/electron-updater/src/AppUpdater.ts:220:35)
    at AutoUpdateService.<anonymous> (/Applications/Fiddler Everywhere.app/Contents/Resources/app/out/services/auto-update/auto-update-service.js:77:74)
    at Generator.next (<anonymous>)
    at fulfilled (/Applications/Fiddler Everywhere.app/Contents/Resources/app/out/services/auto-update/auto-update-service.js:4:58)
[2020-09-24 09:38:58:634] [error] Error: net::ERR_MANDATORY_PROXY_CONFIGURATION_FAILED

 

Hello Geoff,


Thanks for the detailed description of your issue and the provided log files. From the logs, it looks like your environment is using a PAC file (proxy auto-config file), which uses a pacScript. The most likely reason you cannot authenticate successfully (and use Fiddler Everywhere from that point on) is that the pacScript is not providing direct internet access to one of the required endpoints needed by Fiddler Everywhere. To resolve your issue, you could try on of the following options:

If possible, entirely remove the pacScript (if your network administrators are allowing that and you can access the Internet without the pacScript setup).


- Alternatively, you could modify the pacScript so that it contains the required endpoints.



Login to start a new topic