Login to start a new topic

Can not decode HTTPS

Hi, I downloaded fiddler-everywhere-1.1.0.AppImage from here. I followed the instructions for Linux by going to the HTTPS tab in Settings.  It was slightly different than the screen-grab in the instructions - no "Advanced Settings":

image


Nevertheless I successfully downloaded the root certificate (FiddlerRootCertificate.crt).


However, there are still no HTTPS entries:

image



I have the same issue.  I followed these direction exactly.
https://docs.telerik.com/fiddler-everywhere/get-started/configuration


1 person likes this

Hey everyone,


There is no "Advanced settings" on Linux as on Linux, you need to manually export and install the root certificate. So you should directly use the "Export root certificate on Desktop" button and then get the certificate, and add it to OS. 


Note the following:

Some Linux distributions like Ubuntu will use localized paths (for example, the Desktop folder is renamed with the related word used in the locale language). That might cause for step 3 to fail due to a missing folder named Desktop with an error message of type Could not find a part of the path .... Until an out-of-the-box solution is implemented, you could easily workaround this issue by creating a folder called Desktop at your root directory (mkdir ~/Desktop) and then export the certificate to the newly-created directory. Once the certificate is installed, you could safely remove the directory. 


Hi Nick.  Thanks for that info.

I will Google it and probably be able to work it out, however it is not immediately clear to me how to manually add the root certificate.  It would be helpful if you could explain that - and ideally put it in the docs.


Thank you  for your reply anyway.

Hi again: I did try adding the FiddlerRootCertificate.crt - all seemed good.

Still no HTTPS entries though!  Is there something else I need to do?

Hey Richard, 


The manual steps for adding the trust certificate are listed in details in this documentation article. Apart from that you should also verify that the browser you are using is automatically using the system proxy (if not then set the Fiddler proxy in the browser proxy settings).

Hi Nick, thanks for the response.  I have completed the steps of the article so that the "Capture HTTPS Traffic" checkbox is available and selected.  Still, no HTTPS records appear - even when I'm connected to an HTTPS websocket and many HTTP records appear and are active..


Therefore perhaps it is the second part of your answer that I must apply.  You say "verify that the browser you are using is automatically using the system proxy" - I'm not sure how to verify that.
Also, "if not then set the Fiddler proxy in the browser proxy settings": it's not clear to me how to do this.

I'm using Ubuntu.  I have no network proxy currently.
I suppose you are suggesting I put a Fiddler URL in the HTTPS Proxy box?

image


Login to start a new topic