Login to start a new topic
Answered

fiddler everywhere connect itself to proxy

im testing fiddler everywhere the second time and it prompt error "err_proxy_connection_failed". (attach screen capture)


thus unable to sign-in to fiddler from the fiddler everywhere app.


the first time i launch fiddler, i change to the connection to listen on 8080. it was all working fine, able to capture traffic from browser.


im not using any proxy on my linux, and my network do not use proxy.


anyone has solution for this?


Best Answer

Hey Koonmun25,

Thanks for providing this information. Fiddler Everywhere uses the dconf settings for setting/getting the proxy configuration. Looks like the UI in your system stores the data in different location.
In order to remove the setting, you can use the dconf-editor and remove the org.gnome.system.proxy
After that restart Fiddler Everywhere and it should work fine.

Can you try the suggested approach and inform us if it works on your side?

Regards,
Rosen Vladimirov


Hey Koonmun25,

It seems like when Fiddler Everywhere starts, there's a proxy set on your machine. It could be a leaked proxy setting from previous Fiddler Everywhere run or from some other tool. In order to test this, can you please try the following:
1. Ensure Fiddler Everywhere is stopped.
2. Open your Operating System network settings and ensure proxy is not set there. If there's something set, please clean it and disable the proxy.

3. Start Fiddler Everywhere


If this does not help, can you please send us the following information:
1. Your OS name and version.

2. Your Desktop version - if it is Linux, does it use Gnome, KDE, etc.

3. Your Logs located at:
- Linux: `~/.config/Fiddler\ Everywhere/Logs`
- macOS: `~/Library/Application\ Support/Fiddler\ Everywhere/Logs`
- Windows: `%APPDATA%/Fiddler Everywhere/Logs`

Regards,
Rosen

Hi Rosen,


Thanks for your help.


the steps provided to test, tried a few time and it does not work. Fiddler Eveywhere still pick up the proxy setting 

image


I did not set any proxy setting on my machine. Proxy setting for the network adapter is set to none.

image


I use firefox and proxy is set to none, i have no issue connecting to the network and Internet.


If i run a "charles proxy" on port 8080 on my machine, and I start Fiddler everywhere, it will load successfully and able to sign-in to fiddler smoothly.


where and which location or file exactly Fiddle Everywhere read and pick up this proxy setting on my Linux machine from?


my machine
1. kali linux OS Debian-derived

Linux kali 5.7.0-kali1-amd64 #1 SMP Debian 5.7.6-1kali2 (2020-07-01) x86_64 GNU/Linux

2. Desktop is XFCE



I have attach the log 

log
(187 KB)
log
(28.7 KB)
Answer

Hey Koonmun25,

Thanks for providing this information. Fiddler Everywhere uses the dconf settings for setting/getting the proxy configuration. Looks like the UI in your system stores the data in different location.
In order to remove the setting, you can use the dconf-editor and remove the org.gnome.system.proxy
After that restart Fiddler Everywhere and it should work fine.

Can you try the suggested approach and inform us if it works on your side?

Regards,
Rosen Vladimirov


2 people like this

Thanks Rosen


You point me to the right direction.

The org.gnome.system.proxy setting for my machine cannot be remove.

After I go into HTTP and HTTPS subfolder to remove the setting from there, Fiddler Everywhere now works. Enable to sign-in and get connected.

image


image


Hey Koonmun25, 

I'm glad it helped. Can we consider this case as resolved? Are you able to stop Fiddler Everywhere and then start it again without manually modifying the dconf settings?

Regards,
Rosen Vladimirov

Hi Rosen,


Its resolved, setting is permanent.

Restart both Fiddler and OS a few times. All working good now.


Thanks again


Rgds,

koonmun


1 person likes this

Rosen,


your dconf-editor suggestion helped me.

I had to set the system/proxy/mode to the default of 'none', then fiddler stopped having the proxy error.


Thanks

Proxy server is an intermediary server between client and the internet. ERR_PROXY_CONNECTION_FAILED is a browser-based error, which can occur on any Windows OS version when there are some problems with proxy settings. This error means your browser is not able to connect to the internet because of the proxy connection. Either you have invalid proxy connection or configuration of proxy is controlled by the third party.


This err_proxy_connection_failed can be fix by some methods like, Changing Proxy Settings. To change proxy settings: Open the google chrome and click on customize and control google chrome, scroll down to the last part of the web page and click on show advanced settings and click on change proxy settings, there will be a pop up Internet Properties, Now navigate to the Connection tab and then after click the LAN settings button, now you will see the Local Area Network (LAN) Setting do it carefully, and untick the check mark adjacent to Use a proxy server for your LAN and click OK, at last close all windows.


Also, you can usually solve this issue with the following steps:


  • Renew IP address
  • Delete Proxy Server Registry Key
  • Reset TCP/IP


 

 

 

 

Login to start a new topic