Login to start a new topic

Unable to capture request

Hello,

Fiddler cannot run correctly on my mac. After I opened fiddler, I opened chrome to access the URL and it was not captured. My mac version is macOS Catalina10.15.7. I have closed other proxy applications before opening fiddler. But fiddler still cannot run correctly. 

Please help.


1 person has this question

Hey,


Sorry to hear that you have trouble running Fiddler Everywhere on your macOS.


Can you please let us know if you were experiencing the issue with non-secure HTTP or with secure HTTPS traffic (or both)? Are you by chance using any third-party security tool, firewall, VPN? Also, you could post the Fiddler Everywhere logs. Refer to the following KB articles for more details on how to troubleshoot your case:


https://docs.telerik.com/fiddler-everywhere/knowledge-base/accessing-fiddler-logs


https://docs.telerik.com/fiddler-everywhere/knowledge-base/troubleshoot-mac-proxy-settings


https://docs.telerik.com/fiddler-everywhere/knowledge-base/troubleshoot-traffic-capturing

Hey Nick & thanks for your response.


I've found the problem, but I don't know how to solve it. When I turned on Fiddler Everywhere, it didn't set up the system proxy, I already set it to automatically enable the proxy, but that didn't help. Fiddler Everywhere worked correctly after I tried to manually turn on the proxy. Here's the run log

log
(37.8 KB)
log
(20.3 KB)

Fiddler Everywhere should set the proxy to manual (and by default set IP 127.0.0.1 with port 8866) only when Live Traffic Capturing mode is on. Pausing the live traffic should reset your OS proxy settings (this is expected) so that you could continue to use the default Internet connection. Please let us know if the issue is appearing when Live Traffic is set to Capturing and, in this case, provide the output from the commands provided in this article: 


https://docs.telerik.com/fiddler-everywhere/knowledge-base/troubleshoot-mac-proxy-settings 

Sorry, English is not my native language. Please forgive me if I can't describe things clearly.


Before starting Fiddler Everywhere, I made sure that firewalls and other VPN software were down.


I've made sure Fiddler Everywhere is initialized with "live traffic" set to "capture." Here's a picture of what happened.

It looks like Fiddler Everywhere is not able to set your OS proxy settings. Try to reinstall the FE client, and if you still encounter the same issue, then you could try to troubleshoot your macOS proxy setting s via the methods described in this KB article. 

I have reinstalled FE, but FE still cannot set my OS agent Settings. After checking, I found that FE could access the OS network Settings normally, but FE did not set the agent when I opened the capture. The following is the output command after opening the agent

image

Could you post the output for the web proxy (HTTPS) and the secure web proxy (HTTPS)? Those are actually the only two proxies that Fiddler Everywhere will set (when capturing is on).


networksetup -getwebproxy "Wi-Fi"
networksetup -getsecurewebproxy "Wi-Fi


This is the result I output according to your request.

image


Fiddler Everywhere needs administrative rights to set the proxy settings on your OS (when capturing is ON the Fiddler proxy 127.0.01:8866 is set for web proxy and secure proxy). However, in your case, it looks like that your account has limited rights, and the proxy settings can't be set manually or via Fiddler (that is based on the inactive proxy settings in the OS screen you have previously shared). 


Could you let us know if you can manually change the proxy settings for the "Wi-Fi" connection.? If not, you need to contact your OS administrator and ask him to provide rights so that Fiddler Everywhere could change the proxy settings.

The account I used is the administrator account. If I manually set the agent to 127.0.0.1:8866 in the agent setting, FE can normally capture the request. I don't know what caused FE to fail to set up my agent.

If you have a minute, do the following - set the proxy manually, start FE, start capturing, then stop capturing and lastly, send us the logs files (see how to obtain the Fiddler log files here). 

I think there is something wrong with the operation sequence you told me. If I set the agent manually first, it will lead to the failure to access the network, so I cannot log in FE. I changed the order of execution, first turned on FE, and then set the proxy manually.Hope these logs are helpful.

log
(6.31 KB)
log
(24.8 KB)

1 person likes this

Hey there,


The order issue makes sense! 


Could you let us know if Fiddler Everywhere continues to work correctly once the proxy is set manually (FE started > proxy set manually > start capturing > stop capturing > close FE > start FE > start capturing)? Will appreciate it if you delete the Fiddler Everywhere logs before the above operations so that you could generate new clean log files. Additionally, please let us know how the request is made (what browser or application are you using to make the HTTPS requests) and if the used application has some proxy settings that need to be configured alongside Fiddler Everywhere. 

我已经按照您的要求重新生成了日志。我使用Chrome和某些Apple同步程序发送了请求。我认为这些程序都不需要重新配置代理。

log
(9.78 KB)
log
(4.67 KB)
Login to start a new topic