Login to start a new topic
Answered

Unable to capture request

Hello,

Fiddler cannot run correctly on my mac. After I opened fiddler, I opened chrome to access the URL and it was not captured. My mac version is macOS Catalina10.15.7. I have closed other proxy applications before opening fiddler. But fiddler still cannot run correctly. 

Please help.


Best Answer

Hey  523410611 ,


This sounds like the reason why FE won't set the proxy - it lacks the administrative privileges. We logged this one as a bug, but meanwhile, you should be able to temporarily resolve the issue by doing the following on your side.


  1. Go to “System Preferences” > “Security & Privacy”
  2. Click the lock to make changes.
  3. Click on "Advanced…"
  4. Uncheck "Require an administrator password to access system-wide preferences."

(video reference)


Then, restart FE and enable the capturing.



As an alternative solution, you could manually set the FE proxy before starting to capture the requests. Use 127.0.0.1 for IP and  8866 for port (these are the defaults in FE).


2 people have this question

Merry Christmas to you too! :)


The command is not depending on FE but is how FE uses to set the system proxy on the active adapter. So it should not matter what version of FE you are currently using. In fact, it would be better to try the command with no FE running at all to verify that these commands are being successfully executed at your side.


Note: if the command is successful it will change your proxy settings and you might lack Internet (when Fiddler is not running) so do not forget to reset these changes once the testing is over.

I ran the commands you provided, and each one was an error message: 'command requires administrative privileges'. I am using an administrator account

Answer

Hey  523410611 ,


This sounds like the reason why FE won't set the proxy - it lacks the administrative privileges. We logged this one as a bug, but meanwhile, you should be able to temporarily resolve the issue by doing the following on your side.


  1. Go to “System Preferences” > “Security & Privacy”
  2. Click the lock to make changes.
  3. Click on "Advanced…"
  4. Uncheck "Require an administrator password to access system-wide preferences."

(video reference)


Then, restart FE and enable the capturing.



As an alternative solution, you could manually set the FE proxy before starting to capture the requests. Use 127.0.0.1 for IP and  8866 for port (these are the defaults in FE).

Login to start a new topic