Login to start a new topic

Can't save settings circle just spins over 15 minutes

before and after installing the ceritificate I cannot save settings (no proxy)


1 person has this question

Hello Biestyw,



Could you provide more information about the issue you are facing? Consider delivering the following:


- The OS version.

- The version of the installed Fiddler Everywhere.

- The Fiddler Everywhere log files.

- Detailed description of how the issue is manifesting on your side. Is the settings window responding (are you able to close it and reopen it).


Overall, are you able to capture HTTPS traffic after clicking on Trust root certificate and then closing the settings window and enabling Capturing mode?




Windows 10 1909 I think. I couldn’t find the version of fiddler anywhere but downloaded it two days ago. The setting window opens and I can browse do change the settings. Clicking save is where it just hangs. I was not able to capture https traffic. It also just seems to block the browser hence our trying to turn off the proxy settings. I am doing something different. Since we installed on ms term server and most of the people who need to use fiddler don’t have admin rights and therefore cant install their own copy in app data I copied the one I installed to a separate folder and created a new shortcut to start in that folder. It looks like settings are per user as my installing the cert didn’t take for the other user. This is a very frustrating experience.

granted user admin rights and they installed it. Installed quick but takes a long time to start as with separate folder. Save still just spinning circle after 5 minutes.

My mistake on windows version. It's 2016 data center (1607  14393.4169) and as mentioned is a term server.

Hey  Biestyw,


Indeed Fiddler Everywhere is not supporting your scenario out-of-the-box. Would you like to join a private call with us to talk about your organization's needs (in the context of Fiddler Everywhere) and perhaps discuss possible solutions? If you are interested, please contact me at nikolay.iliev at progress.com, and I will arrange the joint meeting.

Sent you an email

1 person likes this

I have the same story with Everywhere on Windows version 1909.   I click Save and it spins infinitely.  Instead of private conversation, please post the solution publicly.

There was no solution. They said they'd look into it. They said it was complicated by my having it on a terminal server in addition to being on windows server. I haven't heard back since.

Having same issue, I checked the app logs and found some error message.

netcore.log shows that fiddler could not find the settings file.

[2021-03-10 10:53:09:106] [Error] [NETCore] Could not find file 'C:\Users\XXXX\.fiddler\d6xxxxxx-xx75-4d25-96xx-xxxx64ee18\Settings\appsettings.json'.
System.IO.FileNotFoundException: Could not find file 'C:\Users\XXXX\.fiddler\d6xxxxxx-xx75-4d25-96xx-xxxx64ee18\Settings\appsettings.json'.
File name: 'C:\Users\XXXX\.fiddler\d6xxxxxx-xx75-4d25-96xx-xxxx64ee18\Settings\appsettings.json'
   at System.IO.FileStream.ValidateFileHandle(SafeFileHandle fileHandle)
   at System.IO.FileStream.CreateFileOpenHandle(FileMode mode, FileShare share, FileOptions options)

eletron.log: 

  

[2021-03-10 10:47:06:290] [error] {
  constructor: 'Error',
  killed: false,
  code: 1,
  signal: null,
  cmd: `PowerShell -Command "$processesWithTypes = Get-WmiObject Win32_Process | Where-Object {$_.Name -like 'Fiddler Everywhere*'} | Select-Object -Property ProcessId, @{Name='Type'; Expression={If ($_.CommandLine -Match '--type=(\\S+)') {$Matches[1]} Else {'browser'}}};Get-WmiObject Win32_PerfFormattedData_PerfProc_Process | Where-Object {$_.Name -like 'Fiddler*'} | Select-Object -Property @{Name='type'; Expression={$id = $_.IDProcess; ($processesWithTypes | Where-Object {$_.ProcessId -eq $id}).Type}}, @{Name='processName'; Expression={$_.Name}}, @{Name='pid'; Expression={$_.IDProcess}}, @{Name='cpuUsage'; Expression={$_.PercentProcessorTime}}, @{Name='memoryUsage'; Expression={$_.WorkingSet / 1MB}} | ConvertTo-Json"`,
  stack: `Error: Command failed: PowerShell -Command "$processesWithTypes = Get-WmiObject Win32_Process | Where-Object {$_.Name -like 'Fiddler Everywhere*'} | Select-Object -Property ProcessId, @{Name='Type'; Expression={If ($_.CommandLine -Match '--type=(\\S+)') {$Matches[1]} Else {'browser'}}};Get-WmiObject Win32_PerfFormattedData_PerfProc_Process | Where-Object {$_.Name -like 'Fiddler*'} | Select-Object -Property @{Name='type'; Expression={$id = $_.IDProcess; ($processesWithTypes | Where-Object {$_.ProcessId -eq $id}).Type}}, @{Name='processName'; Expression={$_.Name}}, @{Name='pid'; Expression={$_.IDProcess}}, @{Name='cpuUsage'; Expression={$_.PercentProcessorTime}}, @{Name='memoryUsage'; Expression={$_.WorkingSet / 1MB}} | ConvertTo-Json"\n` +
    'Access is denied.\r\n' +
    '\n' +
    '    at ChildProcess.exithandler (child_process.js:308:12)\n' +
    '    at ChildProcess.emit (events.js:210:5)\n' +
    '    at maybeClose (internal/child_process.js:1021:16)\n' +
    '    at Process.ChildProcess._handle.onexit (internal/child_process.js:283:5)'
}

So I guess the root cause here is the PowerShell of my device is disabled due to organization's security policy, and fiddler could not create the settings file. Not sure we are having same root cause, wish help troubleshooting.

 

Microsoft Windows [Version 10.0.18363.1377]
(c) 2019 Microsoft Corporation. All rights reserved.

C:\Users\XXXX>powershell
Access is denied.

 

Hello everyone,


The team is currently investigating the logs provided by Biestyw, and we will need some more time to investigate the problem thoroughly. The issue seems identical to the one that Lambert Yang is reporting and is somehow related to the following outputted error: 


System.IO.FileNotFoundException: Could not find file 'C:\Users\XXXX\.fiddler\d6xxxxxx-xx75-4d25-96xx-xxxx64ee18\Settings\appsettings.json'.


Could you guys please check the file & folder permissions in C:\Users\XXXX\.fiddler, where XXXX is the user running the Fiddler Everywhere application (read & write permissions are needed for that folder).


@Lambert Yang, the error related to PowerShell is not connected the first issue and actually indicates that Fiddler Everywhere won't be able to track the CPU usage (which we are tracking & using only for the error logs)

From .fiddler on down I have full control permission. the Settings folder is empty.

I have the same problem in windows 1909. Any updates on this.

I have the exact same issue on both the Windows and Ubuntu versions of Fiddler Everywhere. I'm on Ubuntu 20.04.01 (5.8.0-40-generic) and Windows 10 Enterprise 1809. Would greatly appreciate an update.

Hey AK  and Vishnuatadoor,


Could you guys please provide the FIddler log files so we could investigate each of your cases separately? As a rule of thumb, check if you have access to the required endpoints and have a stable connection that is not timing out. Also, check for leaked proxy settings in your OS proxy settings window. Lastly, please send us the logs that could be manually extracted, as shown here.

Login to start a new topic