Login to start a new topic
Answered

Closing Fiddler Everywhere breaks my internet connection

Dear support team,


I have Fiddler Everywhere 1.5.1 on Windows 10 machine.


Everything worked ok until I closed Fiddler. That action broke my internet connection.


When Fiddler is up and running, my internet connection works properly.


Please advise how to solve this issue.


Kind regards,

Goran


Best Answer

Hey Goran,

Looks like Fiddler Everywhere is still set as proxy, even after closing it. Can you please try the following:
1. Stop Fiddler Everywhere, or at least stop the capturing inside it (the toggle at the top of the Live Traffic tab)
2. Open your OS settings and check if there's anything set for Proxy. If there is , please remove it.
  - If you are using WIndows,  just search for Proxy in the start menu and open the settings in the Control Panel through there.
  - If you are using macOS - open System Preferences, click on Network, then select the currently active adapter on the left side and click on Advanced on the right. Then go to Proxies tab and ensure Web Proxy and Secure Web Proxy are not checked. If they are, please uncheck them, click on OK button to close this dialgo and then click Apply in the network settings.
- If you are using Linux with Gnome UI, just open your network settings and ensure there's no proxy set.
- If you are using Linux with any other GUI, you can use the approach described in this KB.

After removing the proxy configuration, you should have internet access without running Fiddler Everywhere.

Hope this helps!

Regards,
Rosen


Answer

Hey Goran,

Looks like Fiddler Everywhere is still set as proxy, even after closing it. Can you please try the following:
1. Stop Fiddler Everywhere, or at least stop the capturing inside it (the toggle at the top of the Live Traffic tab)
2. Open your OS settings and check if there's anything set for Proxy. If there is , please remove it.
  - If you are using WIndows,  just search for Proxy in the start menu and open the settings in the Control Panel through there.
  - If you are using macOS - open System Preferences, click on Network, then select the currently active adapter on the left side and click on Advanced on the right. Then go to Proxies tab and ensure Web Proxy and Secure Web Proxy are not checked. If they are, please uncheck them, click on OK button to close this dialgo and then click Apply in the network settings.
- If you are using Linux with Gnome UI, just open your network settings and ensure there's no proxy set.
- If you are using Linux with any other GUI, you can use the approach described in this KB.

After removing the proxy configuration, you should have internet access without running Fiddler Everywhere.

Hope this helps!

Regards,
Rosen

I got the help from Lance McCarthy (member of your support team) via Twitter.

Here is what he advised:


I think it still might the same fundamental problem though, try uninstalling fiddler everywhere so that the proxy network adapter is removed. Then reinstall it again.


That worked for me.

Login to start a new topic