Login to start a new topic

Unable to complete the login process due to a backend error

Login to the Fiddler Everywhere 1.6.0 gives this message after a minute trying:


Unable to complete the login process due to a backend error


This is definitely not a user/password issue because bad password tells me just that.  It accepts the credentials initially and can't process whatever on the back end.


What does this mean and how can this be resolved?  It seems silly I can't use an app installed on my Windows 10 Version 1909.


1 person has this question

Hey Marc,

Can you please share your application logs? You can find them by using the Help -> Open Application Logs Folder from Fiddler Everywhere. We'll need all the files in the directory for investigation. 
Also, are you working behind some corporate proxy or firewall? Fiddler Everywhere needs access to several *.getfiddler.com endpoints and if for some reason this is not possible, the application will show you the mentioned error message.

Regards,
Rosen Vladimirov

I am having the same issue. I am also behind a corporate proxy which I have no control over.


It seems ironic to me that a tool whose very purpose is to examine detailed information about http requests is itself unnecessarily crippled by an incorrect practice with a frivolous request. I say frivolous because I do not need to log in to use the tool, it is a business requirement added to the new Fiddler probably for good reasons but completely parenthetical to my requirements for what I am trying to do.

Milton,


I was able to resolve this issue by doing a complete uninstall of Fiddler.  I manually got rid of any and all Fiddler files, including in the AppData dir (if using Windows).  A new install resolved the aforementioned issued I wrote about earlier.  I was relieved to use the app again.  I don't know what the tweaked setting(s) it was that confounded the use of the Fiddler app.  


Marc

Thank you for the tip Marc. Fortunately I am on Windows so I simply reverted to Fiddler classic which is working as it always did, without any sign in needed.

I am using the Classic.  The new Everywhere just doesn't work everywhere.

Rosen,


Attached are the two log files.


I do have a corp proxy URL I would use if known where/how to add it into Fiddler Everywhere.  This may be the same issue I have with Fiddler Classic where it worked fairly flawlessly until I received this new Windows machine and I hadn't seem to resolve.  Any info how to address the proxy issue for both Everywhere and Classic would be appreciated.


Thanks,

Marc

log
(9.31 KB)
log
(9.87 KB)

Hey Marc,

Thanks for the logs. Based on them we have two suggestions what might cause the issue:
- Your PAC script rejects the access to some of our *.getfiddler.com APIs.
- We have an issue with respecting the default proxy configuration during startup of the app,  we are working on it and we'll have it fixed soon, but we need to check if this is causing the troubles on your side.

In order to verify the reasons for the error, can you try the following:
1. Open https://dashboard.getfiddler.com and try to sign in. Is the operation successful? Do you see any errors in browser's DevTools?

2. Open https://api.getfiddler.com/ - do you see a browser prompt to sign in or the page just does not load (note, you will not be able to sign in with your credentials, it is important to see the prompt)? 

If both of them are working, most probably the issue is the one I've mentioned - where some of the requests we execute from Fiddler Everywhere to get information about the user and cloud resources, does not respect the system proxy. The only workaround for it at the moment is to ensure *.getfiddler.com APIs are accessible even without your proxy.

Regards,
Rosen Vladimirov

Both Steps #1 and #2 are a success.  Do you have an ETA when "fixed soon" will be?  In the meantime, I'll look at accessing the *.getfiddler.com.


Thank You,

Marc

Login to start a new topic