Login to start a new topic

Unable to login behind corporate proxy on my Mac

Corporate proxy is configured using system settings, using a PAC file and Kerberos auth. I also have a local proxy running for edge cases. I have tried setting http_proxy and https_proxy environment variables, but no luck.


How can I change the proxy settings for this Electron-based application so that I can log in and begin using it? (I also don't like that I have to login to use the desktop app in the first place, but I'm willing to see if it's any good)


Also, the logged output when starting up shows:

01:14:05.746 › Setting the following proxy settings to the main window: {"pacScript":null,"proxyRules":null,"proxyBypassRules":"*.local;169.254/16"}


I also tried modifying browser-window-service.js to set the proxy following the documentation here: https://www.electronjs.org/docs/api/session#sessetproxyconfig


With this code change:

 

const upstreamProxyConfig = {
                    proxyRules: 'http=localhost:9876;https=localhost:9876'
                };
                this.logger.info(`Setting the following proxy settings to the main window: ${JSON.stringify(upstreamProxyConfig)}`);
                mainBrowserWindow.webContents.session.setProxy(upstreamProxyConfig);

 

But it still didn't work.


Hey Sean,


Thanks for providing the additional information - we can confirm that there is an issue with FIddler not using the upstream proxy for each call to the login API. As a result, this leads to a failing login issue. We are currently working on a fix, and I will update the thread as soon as the patch is ready.


1 person likes this

Hi Matt,


Reviewing the provided logs, we've found out that we are not able to reach api.getfiddler.com from Fiddler Everywhere and there is a system PAC script set on your machine.


I suggest you try removing this system PAC script, restart Fiddler Everywhere, and try to log in again. In order to use a PAC script with Fiddler Everywhere, ensure that the script is returning a valid value for all api.getfiddler.com requests, otherwise, we will not be able to complete the login process.


Regards,

Dimitar


1 person likes this

Hi Dimitar,

Thanks for your response.  I'll try that.


I've deleted my message from yesterday in order to delete the log files.  Here's the message itself:


Hi Rosen. 

Thank you for continuing to work on this.

I opened Fiddler Everywhere this morning, after seeing your comment above, and it automatically downloaded and installed the update.

But when I logged in I got this error message: "Unable to complete the login process due to a backend error."

I tried again with the same result.

Logs attached.

thank you,

Matt


1 person likes this

Hey Matt, 

The initial issue of Fiddler Everywhere not respecting the upstream proxy has been fixed. Can you please give us more details about your issue and maybe send your Application logs for investigation?


Regards,

Rosen 

I was able to make what seems to be minor progress with a full system restart (despite that everything else was working fine on the machine). I was able to switch between Kerberos PAC-based proxy and a manually configured one, and in both cases I'm now seeing the error on login:


"Unable to complete the login process due to a backend error."


What now?


Thanks!

In addition, I switched from username/password based login to SSO with Google (which succeeded in the browser), but Fiddler Anywhere still sat there for a while and eventually errored out with the same message. For what it's worth, I think the connection isn't the problem now, as the update check succeeds:


 

12:29:19.149 › Checking for update
12:29:20.791 › Update for version 1.6.0 is not available (latest version: 1.6.0, downgrade is disallowed).

 Still stuck.

Hello Sean,


Thank you for reporting your case and providing a detailed description of your network setup and steps taken during the debugging process!


The team is currently investigating a possible issue with some Fiddler requests not respecting a passed upstream proxy. Could you please let us know if you have access to https://api.getfiddler.com when no PAC script is configured on your side? I would expect you to face the same issue (not being able to complete the login process) when no PAC script is involved, which will confirm that you are dealing with the same scenario. If that is the case, then please stay tuned as we are actively working on a solution for this bug.

I can confirm that with the proxy off, we can't connect:

curl: (7) Failed to connect to api.getfiddler.com port 443: Connection refused


But when I enable the proxy, it works, and I get an empty response, but the connection succeeds.

Hi,

Has there been any progress in patching this?  I'm experiencing the same issue.

thank you

Login to start a new topic