trust root certificate......failed


I've already export and add the certification into my system key-chain, but I still fail to start the Fiddler. Besides, where to find my logs? On macOS

You could troubleshoot the build-in certificate export and trusting flow by following the steps as described in this KB article:

The Fiddler logs files are accessible through the main menu (Help > Open Application Logs Folder), or alternatively, you could access them manually as described here:

As the error indicates, the Fiddler Everywhere application is unable to find/use the OS keychain and use it to import the root trust certificate. The error might indicate that you lack administrative rights to access and modify the OS keychain or that the keychain app is inaccessible for some other reason. You could export the certificate through Settings > HTTPS > Advanced Settings > Export root certificate (the command will export the certificate to your Desktop directory) and then import it manually in your OS keychain.

1 person likes this

Thank you Nick for your replying. I've tried the method you suggested and the problem remains unsolved. I followed and couldn't find trustSettings.xml. 


Here are my logs and a snapshot of the troubles.

(396 KB)
(288 KB)
(304 KB)

The logs indicate that Fiddler Everywhere is unable to find the login folder in your macOS Keychain application. This folder is usually created by default during the OS installation, but if it is not present, Fiddler Everywhere won't install the trust certificate. Make sure to recreate the folder in the Keychain application and then retry the Fiddler Everywhere trust certificate flow.