Login to start a new topic

Failed to capture my android app https traffic while works for iOS

My android app always complains "The server returns invalid data" for the very first https request. I would assume the server here means fiddler. I have not figured why that happened. And I tried many times on my android, occasionally fiddler can capture traffic but when it worked I did not figured out what I did differently. Fiddler can capture https traffic on my iPhone for the same app.


BTW, fiddler can capture https traffic from chrome browser. I am not sure if this is because the answer in here https://stackoverflow.com/questions/62730978/some-androids-apps-wont-connect-through-fiddler said "One of those rare apps that respect user CA certificates is Chrome. So using Chrome for testing if the proxy and the installed root CA certificate works is a bad idea, as it may only work in Chrome but not for apps."


But the problem is fiddler occasionally captures!


image

The error for the vert first http request from my android app.

The above capture is a non-secure HTTP session that Fiddler Everywhere captures easily without using a trusted certificate. It sounds like the Android application that HTTPS traffic you are aiming to capture is not respecting the Fiddler trust certificate. This is the expected behavior for almost all Android applications in production. The solution is to explicitly configure the application to use the Fiddler certificate (this requires access to the app codebase and a complete rebuild of the application). 

I'm having the same issue since the release of v3.0.0 and 3.0.1 and I keep downgrading to 2.2.0 which is the last version on Mac that is working fine. Unfortunately I have to re-install it every freaking time I close it because I can not figure how to stop the automated update...
If I run the latest version on Windows, I don't have such issues with the android apps.
I've twitted about this on December 10th https://twitter.com/cbotsikas/status/1469261209992151048

The email I've sent back then was:

Since the update to version 3.0.0 and now to 3.0.1 I'm having issues with some/most/all (not sure) requests not being able to be processed on my mobile apps (hybrid native/ionic and react native). Not sure what changed and don't have time to investigate. All I know is that when I use fiddler, the requests can't be processed by the app, but when I deactivate fiddler everything works just fine.
Is it somehow possible to downgrade to 2.2.0 which was working fine for me?

It's a big blocker for my work at the moment and I need to catch deadlines..


From what I was able to debug a bit, I was getting errors like ERR_INVALID_CHUNKED_ENCODING or  java bufferedreader java.net.ProtocolException: Expected leading [0-9a-fA-F] character but was 0x0

Login to start a new topic