Login to start a new topic
Answered

Fiddler Everywhere issue

When I use fidder, the response status code is 500, and when I use curl to test or web access, the response is normal and status code is 200 .


https://www.misumi.com.cn/



image


image



Best Answer

The composed request you are executing is missing the User-Agent header, which all browsers add by default. Fiddler Everywhere also adds the header with a default value, so I guess the header was explicitly removed during the test process. The server is unhappy with the missing header, which leads to the internal server error and the received status code. The solution is to introduce the User-Agent header, and you will be able to execute the request as expected.



Answer

The composed request you are executing is missing the User-Agent header, which all browsers add by default. Fiddler Everywhere also adds the header with a default value, so I guess the header was explicitly removed during the test process. The server is unhappy with the missing header, which leads to the internal server error and the received status code. The solution is to introduce the User-Agent header, and you will be able to execute the request as expected.


https://www.misumi.com.cn/

The above URL needs to be added with user-agent

But other addresses can not add user-agent. Is this caused by the problem of the origin site setting of the domain name?


https://www.misumi.com.cn/

https://help.aliyun.com/document_detail/106661.html


image


image


While the User-Agent header is optional (as stated in RFC2616), some servers might be configured to not work without it to avoid (or at least try) spoofing and incompatible content being passed to a client that don't understand it. Virtually all modern-day browsers (and most desktop applications making HTTP requests) add the User-Agent header. So it is safe to say that the User-Agent is more or less widely used and not so much an optional header.


That said, it looks like the server behind that specific domain is not handling responses that lack the User-Agent header, which produces the 500 status error.

OK,Thanks

Login to start a new topic