Fiddler composer body selection not working


it seems that the checkboxes in the body tab of the composer is not working as expected.

I tried to uncheck a body parameter so that I can test a request without that parameter only.

But when I check the live traffic caused by the composer, the body parameter still appears on the inspector.

The only way to remove a parameter from a composer is to completely remove the parameter using the trash button, which I do not want because then I would have to rewrite the body parameter on my later request.

please fix the bug.


Hey Jack,

We've tried to reproduce the described issue but to no avail. Unchecking selected headers is actively removing them from the requests execution.

For example, here is the same Composer request with and without some of the its headers checked.

and with some headers unchecked

Can you elaborate more on your specific case and perhaps provide steps that we can reproduce.

Hi Nick, I have confirmed that unchecking selected parameters in the "headers" tab works correctly.

But I have problems with unchecking the "body" tab. 

I set my header's "Content-Type" to "application/x-www-form-urlencoded", 

I put a key / value parameter in the body, and I send a request.

After, I uncheck the parameter in the Body tab and I execute the request but still appears on the inspector.

Please check again.


here are the issues that i have :(